ROBIN -  Open Source Mesh Network Forum Index ROBIN - Open Source Mesh Network
users community forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

2610 incorrect txpower settings?

 
Post new topic   Reply to topic    ROBIN - Open Source Mesh Network Forum Index -> beta-1.5 Release Candidates
View previous topic :: View next topic  
Author Message
Ads






Posted: Thu Nov 23, 2017 5:28 am    Post subject: Ads

Back to top
mtlowes
Moderator
Moderator


Joined: 28 Oct 2009
Posts: 577
Location: Lakeshore Ontario Canada

PostPosted: Tue Mar 16, 2010 1:32 pm    Post subject: 2610 incorrect txpower settings? Reply with quote

I've been examining 2 of my 2610's and comparing them to other 2610's in the network.. typically I see this:

All 2610's running 2690 firmware. Why the discrepency?.. The first readings are normal considering the internal offset that comes with 2610's.. the second I am uncertain about since its different than all the rest of the units on the network and are the ones underperforming...

Any ideas suggestions on how to correct this?

****UPDATE*****
Flashed a new one to 2681 and the txpower reading was correct.. upgraded it to 2690 and its nolonger reading txpower correctly.. flashing back to 2681

iwlist txpower:
ath0 8 available transmit-powers :
0 dBm (1 mW)
7 dBm (5 mW)
9 dBm (7 mW)
11 dBm (12 mW)
13 dBm (19 mW)
15 dBm (31 mW)
17 dBm (50 mW)
19 dBm (79 mW)
Current Tx-Power:19 dBm (79 mW)

On 2 units that are under performing i get this response:
ath0 8 available transmit-powers :
0 dBm (1 mW)
8 dBm (6 mW)
10 dBm (10 mW)
12 dBm (15 mW)
14 dBm (25 mW)
16 dBm (39 mW)
18 dBm (63 mW)
20 dBm (100 mW)
Current Tx-Power:20 dBm (100 mW)
Back to top
View user's profile Send private message
sedatkaan
Skilled User
Skilled User


Joined: 30 Jan 2009
Posts: 217

PostPosted: Tue Mar 16, 2010 9:50 pm    Post subject: hi Reply with quote

/etc/profiles/default/etc/wireless_1-default change option country 840

and reboot.
Back to top
View user's profile Send private message
sbe
Intermediate User
Intermediate User


Joined: 28 May 2009
Posts: 119
Location: Cookeville, Tennessee, USA

PostPosted: Wed Mar 17, 2010 12:40 am    Post subject: Reply with quote

I can confirm that on my 2610 running 2690 the power output was at 20 dBm also.

Updated the country code to 840, know showing 19 dBM in iwlist, but no increase in effective signal strength. If anything a 1 dBm decrease while looking at the RSSI timeline before/after the change.

What was the original country code, I'd like to change it back, but did not make a note of what it was?
Back to top
View user's profile Send private message
mtlowes
Moderator
Moderator


Joined: 28 Oct 2009
Posts: 577
Location: Lakeshore Ontario Canada

PostPosted: Wed Mar 17, 2010 12:51 am    Post subject: Re: hi Reply with quote

sedatkaan wrote:
/etc/profiles/default/etc/wireless_1-default change option country 840

and reboot.


Thanks.. that did it.. wonder why it didn't set itself to begin with.. anyway.. see if that helps sort some things out..

thanks again.
Mike
Back to top
View user's profile Send private message
ispyisail
Site Admin
Site Admin


Joined: 12 Sep 2008
Posts: 4604
Location: New Zealand

PostPosted: Wed Mar 17, 2010 5:05 am    Post subject: Reply with quote

In r2690 we changed the country code to Japan so we could get 14 channels what we didn't factor in was the drop in maximum power output.

see
Only registered users can see links on this forum!
Register or Login on forum!


_________________
ROBIN-Mesh Wiki:

Only registered users can see links on this forum!
Register or Login on forum!

Test Network:
Only registered users can see links on this forum!
Register or Login on forum!



Please donate to ROBIN by paypal:

Only registered users can see links on this forum!
Register or Login on forum!

!
Back to top
View user's profile Send private message
mtlowes
Moderator
Moderator


Joined: 28 Oct 2009
Posts: 577
Location: Lakeshore Ontario Canada

PostPosted: Wed Mar 17, 2010 11:57 am    Post subject: Reply with quote

ispyisail wrote:
In r2690 we changed the country code to Japan so we could get 14 channels what we didn't factor in was the drop in maximum power output.


So.... more simply put... OOPS! Wink
Perhaps leaving it at a default US country code or something other than Japan as I imagine most will not use channels 12-14 since 1) its illegal in most areas other than japan etc and 2) not very conducive to enabling connections to client laptops & devices etc..

Maybe just make the alternate country code an option instead of a default.

Just a thought.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ROBIN - Open Source Mesh Network Forum Index -> beta-1.5 Release Candidates All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
c d
e



Powered by phpBB © 2001, 2005 phpBB Group

Abuse - Report Abuse - TOS & Privacy.
Powered by forumup.it free forum, create your free forum! Created by Hyarbor & Qooqoa
Confirmed

Page generation time: 0.464