ROBIN -  Open Source Mesh Network Forum Index ROBIN - Open Source Mesh Network
users community forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Orangemesh for Layer 2 mesh - Unable to receive http respons

 
Post new topic   Reply to topic    ROBIN - Open Source Mesh Network Forum Index -> OrangeMesh Dashboard
View previous topic :: View next topic  
Author Message
Ads






Posted: Mon Jun 26, 2017 7:51 am    Post subject: Ads

Back to top
gaargie
User
User


Joined: 17 Dec 2008
Posts: 16

PostPosted: Thu Apr 02, 2009 11:34 pm    Post subject: Orangemesh for Layer 2 mesh - Unable to receive http respons Reply with quote

Hi

I am trying to adapt orangemesh dashboard for Layer 2. I have made some changes to the scripts.

Now my Gateway node (G) can communicate to the orangemesh server. Gateway is connected to other nodes wirelessly (N1). The node which is wirelessly connected has clients (C1) (C2).

The node N1 one hope away from G - is unable to receive HTTP response once I execute the update script. Hence I am unable to check in.

The connection is terminated by the orangemesh server. HTTP request gets sent but no response is received.

My update.log is as shown below:

DEBUG output created by Wget 1.11.4 on linux-gnu.

--1970-01-01 13:26:25--
Only registered users can see links on this forum!
Register or Login on forum!


Connecting to 172.16.10.63:80... connected.
Created socket 5.
Releasing 0x0045bad8 (new refcount 0).
Deleting unused 0x0045bad8.

---request begin---
GET /gargi-orange//checkin-batman.php?ip=192.168.50.25&mac=00:FF:45:1E:BE:F6&robin=r1590-28/nO&batman=0.5.6-r3&memfree=110172&ssid=&pssid=mymesh&RR=0&users=0&kbup=0&kbdown=0&uptime=0d:19h:26m-90&gatewa
User-Agent: Wget/1.11.4^M
Accept: */*^M
Host: 172.16.10.63^M
Connection: Keep-Alive^M
^M
---request end---
HTTP request sent, awaiting response... No data received.
Closed fd 5
Retrying.

--1970-01-01 13:27:27-- (try: 2)

Only registered users can see links on this forum!
Register or Login on forum!


Connecting to 172.16.10.63:80... connected.
Created socket 5.
Releasing 0x0045bad8 (new refcount 0).
Deleting unused 0x0045bad8.

---request begin---
GET /gargi-orange//checkin-batman.php?ip=192.168.50.25&mac=00:FF:45:1E:BE:F6&robin=r1590-28/nO&batman=0.5.6-r3&memfree=110172&ssid=&pssid=mymesh&RR=0&users=0&kbup=0&kbdown=0&uptime=0d:19h:26m-90&gatewa
User-Agent: Wget/1.11.4^M
Accept: */*^M
Host: 172.16.10.63^M
Connection: Keep-Alive^M
^M
---request end---
HTTP request sent, awaiting response...


Any inputs would be appreciated
Back to top
View user's profile Send private message Yahoo Messenger
shasan
Moderator
Moderator


Joined: 16 Feb 2008
Posts: 178
Location: Chapel Hill, NC

PostPosted: Fri Apr 03, 2009 5:18 pm    Post subject: Reply with quote

My initial thought is that your GET request is incomplete. See at the end of it how it says "&gatewa"? I can't remember off the top of my head if the script will die on a malformed status request, but that's the most suspect thing of the output you've posted.

Also, verify that the MAC addresses for your nodes have been added to your dashboard, and that their approval status is "A".

You have two //'s after your hostname, shouldn't affect anything but you might want to fix that too.

One final bit: does it work with Open-Mesh.com's dashboard? Or is it just Orangemesh? Are you able to ping your Orangemesh server from the nodes?

_________________

Only registered users can see links on this forum!
Register or Login on forum!


unc-chapel hill, class of 2010
Back to top
View user's profile Send private message Send e-mail Visit poster's website
gaargie
User
User


Joined: 17 Dec 2008
Posts: 16

PostPosted: Wed Apr 08, 2009 6:17 pm    Post subject: Reply with quote

Well that did not help...

Actually I had mixed network of Routerboards and Merakis. Now I tried to simplify the configuraition so I just have dual radio Routerboards on the network

Now even from the gateway node I am not able to receive updates from the orangemesh server

I get the response as:

root@open-mesh:/etc# cat /etc/update/received
No such network


The node checks in but does not receive any response...
Back to top
View user's profile Send private message Yahoo Messenger
shasan
Moderator
Moderator


Joined: 16 Feb 2008
Posts: 178
Location: Chapel Hill, NC

PostPosted: Wed Apr 08, 2009 6:30 pm    Post subject: Reply with quote

Again, are you able to check in to Open-Mesh.com? Are you able to ping your Orangemesh server from each of your nodes?

_________________

Only registered users can see links on this forum!
Register or Login on forum!


unc-chapel hill, class of 2010
Back to top
View user's profile Send private message Send e-mail Visit poster's website
gaargie
User
User


Joined: 17 Dec 2008
Posts: 16

PostPosted: Wed Apr 08, 2009 10:02 pm    Post subject: Reply with quote

Ok...looked like the SQL table has multiple entries for my MAC. One of the entry has netid as 0 and the other has netid as 34. It takes the first entry and since netid (I dont know what it is or how it is calculated) is 0 it does not proceed

When I remove that conditiion..in checkin-batman.php the gateway node can check in now.


The problem remains with the wireless AP.
Coming again to my config. I have one wired AP (AP1) and one wireless AP (AP2). The wireless AP cannnot ssh/http to the wired backbone where i have my orangemesh server (S1). Any TCP service it cannot initiate.

The client of AP2 (C1) can ssh to orangemesh server.

AP2 can SSH C1
AP2 can SSH AP1
AP2 cannot SSH S1

C1 can ssh AP2
C1 can SSH S1
Back to top
View user's profile Send private message Yahoo Messenger
gaargie
User
User


Joined: 17 Dec 2008
Posts: 16

PostPosted: Fri Apr 10, 2009 2:30 am    Post subject: Reply with quote

Wokkay - the problem was with kamikaze...the trunk did not have the right distro and hence ssh was creating issues

Now it works

Thanks for lending a ear Smile
Back to top
View user's profile Send private message Yahoo Messenger
shasan
Moderator
Moderator


Joined: 16 Feb 2008
Posts: 178
Location: Chapel Hill, NC

PostPosted: Fri Apr 10, 2009 2:39 am    Post subject: Reply with quote

Glad you got it working, you were starting to throw me for a loop!

_________________

Only registered users can see links on this forum!
Register or Login on forum!


unc-chapel hill, class of 2010
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    ROBIN - Open Source Mesh Network Forum Index -> OrangeMesh Dashboard All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
c d
e



Powered by phpBB © 2001, 2005 phpBB Group

Abuse - Report Abuse - TOS & Privacy.
Powered by forumup.it free forum, create your free forum! Created by Hyarbor & Qooqoa
Confirmed

Page generation time: 0.228